Cisco NX-OS: VXLAN BGP EVPN control plane

Two control planes for the VXLAN technology:

  • Multicast control plane (flood-and learn)
  • MP-BGP EVPN control plane

MP-BGP EVPN is a standard-based VXLAN control protocol, that provides remote VTEP discovery and MAC/ARP learning. Ethernet Virtual Private Network (EVPN) reduces flooding in the network and resolves scalability concerns. MP-BGP is used to exchange information between VTEPs

Devices might be MP-iBGP EVPN peers or route reflectors, or MP External BGP (MP-eBGP) EVPN peers.

  • Set switching mode to store-and-forwarding
  • IP unicast reachability between VTEPs
  • PIM BIDIR reachability between VTEPs
  • Enable features
    • install feature-set virtualization
    • install feature-set fabric
    • feature-set fabric
    • feature fabric forwarding
    • nv overlay evpn (Enable the EVPN control plane)
    • vn-segment-vlan-based
    • feature nv overlay

Nexus Spine switches (Router Reflectors) will not be doing any VXLAN encap or decap, therefore only need “nv overlay evpn“. They are advertising the routes between the Leafs.

Follow steps from the post Cisco NX-OS: VXLAN Configuration

conf t
   hardware ethernet store-and-fwd-switching
copy run start
reboot
!
!
feature eigrp
!
router eigrp 100
  address-family ipv4 unicast
    autonomous-system 100
    router-id 1.1.1.1

interface Ethernet1/1
  no switchport
  ip address 172.16.12.1/30
  ip router eigrp 100
  no shutdown

interface Ethernet1/2
  no switchport
  ip address 172.16.13.1/24
  ip router eigrp 100
  no shutdown

interface loopback0
  ip address 1.1.1.1/32
  ip router eigrp 100
!
!
feature pim

ip pim rp-address 1.1.1.3 group-list 224.0.0.0/4 bidir

interface loopback0
  ip pim sparse-mode

interface Ethernet1/1
  ip pim sparse-mode

interface Ethernet1/2
  ip pim sparse-mode
!
!
vlan 10
  vn-segment 101010

Create Network Virtualization Edge (VNE) interface

conf t
interface nve1
  source-interface loopback0
  member vni 101010
    mcast-group 228.7.7.7
  host-reachability protocol bgp

Leafs BGP configuration

An extended community is required. MP-BGP EVPN uses the BGP extended community attribute to transmit the exported route-targets in an EVPN route.

feature bgp

router bgp 1
  log-neighbor-changes
  neighbor 1.1.1.3
    remote-as 1
    update-source loopback0
    address-family l2vpn evpn
      send-community extended
  neighbor 1.1.1.4
    remote-as 1
    update-source loopback0
    address-family l2vpn evpn
      send-community extended

Spine/RR configuration

feature bgp

router bgp 1
  log-neighbor-changes
  neighbor 1.1.1.1
    remote-as 1
    update-source loopback0
    address-family l2vpn evpn
	send-community extended
	route-reflector-client
  neighbor 1.1.1.2
    remote-as 1
    update-source loopback0
    address-family l2vpn evpn
	send-community extended
	route-reflector-client

Verification

show mac address-table
show nve peer
show nve vni
show bgp l2vpn evpn summary
show bgp all neighbors

Advertise MAC addresses into BGP

on both Leafs

evpn
  vni 101010 l2
    rd auto
    route-target both auto
Share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *